Home Forums Arnold WordPress Theme Tablet view – how to set menu/header/nav to hamburger menu?

This topic contains 10 replies, has 2 voices, and was last updated by  BWSM 2 months, 1 week ago.

Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
    Posts
  • #17958

    houndandbone
    Participant

    Hi there!

    Really happy with the theme, thank you! I just have one question. The theme is behaving well in desktop and smartphone mode, however when I check it in tablet mode the menu is too big for the screen. Is there any way of making the tablet responsive mode have a hamburger menu like the smartphone mode does? This would solve our problem.

    Thank you!

    #17959

    BWSM
    Keymaster

    Hi,

    Please paste the custom css code to “Appearance > Customize : Additional CSS”:

    @media (max-width: 768px) {
     .responsive-ux #navi-header {display: none;}
     .responsive-ux #navi-trigger { display: block; }
     .responsive-ux #wrap {   z-index: 999;}
    }

    Edit the file: /js/custom.theme.js, find line 90:
    var switchWidth = 767;
    update to:
    var switchWidth = 768;

    Regards!
    Bwsm – uiueux.comTwitterFacebook

    #17987

    houndandbone
    Participant

    Thanks, but I don’t know how I can edit that file? I have put the CSS into my theme but I am not sure how to edit /js/custom.theme.js.

    #17993

    BWSM
    Keymaster

    Please go to “Appearance > Edit ”
    arnold/js/custom.theme.js

    #17994

    houndandbone
    Participant

    Thanks, but I do not have this option?
    I have a screenshot but I can’t attach it here.

    #17997

    BWSM
    Keymaster

    Please send to uiueux@gmail.com
    You could use FTP to log in website space also.

    #18003

    houndandbone
    Participant

    Can you confirm that you received my email?

    #18004

    houndandbone
    Participant

    Hi,

    I have worked out how to change arnold/js/custom.theme.js and have edited line 90.

    In portrait orientation the hamburger menu is too close to the top of the screen, and in landscape mode it still shows the full menu.
    Can you advise how I can fix this?

    • This reply was modified 2 months, 2 weeks ago by  houndandbone.
    #18008

    BWSM
    Keymaster

    Hi,
    Do you want to show hamburger icon in landscape mode?
    Please update to for line 90:
    var switchWidth = 1024;

    Please leave your website URL, I will check the “icon too close” issue.

    Regards

    #18010

    houndandbone
    Participant

    Hi
    That change gave me both a hamburger menu and the regular menu when in tablet landscape mode.

    This is the URL but our site is under maintenance so you won’t be able to see anything. How else can we fix this?
    houndandbone.com.au

    #18011

    BWSM
    Keymaster

    Please use the Custom CSS to hide regular menu.

    @media (max-width: 768px) {
    .responsive-ux .heade-meta, .responsive-ux.navi-show-h.navi-show-h-left .heade-meta, .responsive-ux .header-bar-social { display: none; }
    }

    If still not work, tell me what’s device screen size you tested, please.

    I need to check the lived page, please send the password to uiueux@gmail.com

Viewing 11 posts - 1 through 11 (of 11 total)

You must be logged in to reply to this topic.

Join Newsletter(FREE)

Subscribe to our newsletter to receive news & updates. We promise to not spam you, super promise!