Home Forums Bee WordPress Theme Problems with modal error in backend

This topic contains 4 replies, has 2 voices, and was last updated by  maciana 3 years, 3 months ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #4080

    maciana
    Participant

    Hi,

    I have a problem with modal windows in the backend. Is the WordPress backend affected by the theme at all?

    Best regards

    #4084

    Johnny
    Participant

    Hi, if you don’t mind please paste your site login info here through private message, I will check it later,
    Thank you

    #4169

    maciana
    Participant
    This reply has been marked as private.
    #4180

    Johnny
    Participant

    Hi, I have logined into you site but find nothing about modal windows. please give me more details,
    Thank you

    #4187

    maciana
    Participant

    Hi,

    I found the culprit: it seems to be an CSS error of the WordPress backend.

    A modal window is opened, that can’t be scrolled or used in any way because the greyed out area is above the modal window content, it’s a z-index error that’s caused by #TB_overlay / thickbox.css.

    If you add the following to the functions.php, the error is removed.

    add_action('admin_head', 'modalwindow');
    
    function modalwindow() {
      echo '<style>
        #TB_overlay {
        z-index: 1;
    } 
      </style>';
    }
    

    It’s strange that this error only occurs when I use your theme, but it may just be a strange coincidence.

    Thanks for looking into it.

    Best regards!

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.