Home Forums Art WordPress Theme Mobile Portfolio Tap/scroll issue

This topic contains 4 replies, has 2 voices, and was last updated by  BWSM 1 week, 6 days ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #18354

    alebi
    Participant

    Hi,
    There is a problem with hover / tap / scrolling on mobile portfolio list page.
    If I touch a portfolio image on portfolio list page, while I’m scrolling the page, mouseover effect appears and if I touch twice the same image (always while scrolling) it opens the link to single portfolio page. It is very, very unlikable, while I’m scrolling that a single portfolio opens.
    Is there a way to have a double tap (close one to each other, like a double click) active on mobile? Is there a way to deactivate mouseover on mobile and activate double tap? Is there any other solution alternative to those that I found here on this forum?
    Thank you so much.
    a.

    #18360

    BWSM
    Keymaster

    Hi,

    It is not an easy job to add double-click to open a single portfolio.

    Solution 1:
    Please edit this fie in art-theme folder(Appearance > Theme Editor). It will be not easy to active mouseover effect and open single portfolio when scrolling.
    /js/theme.custom.js
    find line1102-1103:

    if( _this.hasClass('bm-touch-tab')){
    _this.on('touchend', function(){

    update to:

    if(Modernizr.touchevents && _this.hasClass('bm-touch-tab')){
    _this.on('click', function(){

    This changing will be added in next update also

    Solution 2:
    To open single portfolio by once clicking, pleae edit /js/theme.custom.js
    Remove line 1351
    themeData.fnPofrtoliloFixHover($('.bm-touch-tab'));

    Regards!
    Bwsm – uiueux.comTwitterFacebook

    #18380

    alebi
    Participant

    Thank you!
    First solution is what I was looking for.

    #18483

    alebi
    Participant

    Hi,
    Unfortunately this won’t work on this website: http://www.alebertoncello.it, it has the same settings than this http://37.60.224.167/~agrigra5/aforest.it/ where solution 2 works. How is it possible? Thank you.

    #18491

    BWSM
    Keymaster

    Hi,

    If it worked on the old site, it should work on a new site. Please check what’s different(plugin, setting…) the 2 sites. I found you use child theme, I suggest you test if use origin theme with changed theme.custom.js file.

    PS, it works with solution 1 on the new site now. is it?

    Regards

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.

Join Newsletter(FREE)

Subscribe to our newsletter to receive news & updates. We promise to not spam you, super promise!