Home Forums Panda HTML Theme Don't working correctly on IE10, Chrome and Firefox.

This topic contains 4 replies, has 2 voices, and was last updated by  maps75 4 years ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #783

    maps75
    Participant

    Hi.

    1. The LayerSlider isn’t working correctly on IE10 (the slider don’t appear on the screen).
    My browser indicates the error message: “SCRIPT5007: Can not get property 'getItem' of null or undefined reference. main.js, line 1099 character 5“. See: http://www.maps75.com.br/Panda_Error1.png

    2. The class “head_layout_b“, on “index.html” page, isn’t aligning the logo correctly on Chrome (v.29) and Firefox (v.24). The logo align in center, like “head_layout_a“. See: http://www.maps75.com.br/Panda_Error2.png

    Can you help me urgently, please?

    Best.

    Marco Antonio / Brazil.

    #788

    Johnny
    Participant

    hi, please do this:
    open js/main.js, find this block:
    `var storage = window[‘localStorage’];
    var sw = storage.getItem(‘style-width’);
    var sh = storage.getItem(‘style-header’);
    var sb = storage.getItem(‘style-bg’);
    if (sw == 1) {
    jQuery(‘head’).append(‘‘);
    setTimeout( “jQuery(‘ul#item-wrap’).isotope(‘reLayout’);”,1000 );
    } else {
    jQuery(‘head’).append(‘‘);
    }

    if (sh == ‘b’) {
    jQuery(“#header_wrap”).removeClass(“head_layout_a”).addClass(“head_layout_b”);
    jQuery(“#header_switch”).removeClass(“header_layout_thumb_a”).addClass(“header_layout_thumb_b”);
    } else {
    jQuery(“#header_wrap”).removeClass(“head_layout_b”).addClass(“head_layout_a”);
    jQuery(“#header_switch”).removeClass(“header_layout_thumb_b”).addClass(“header_layout_thumb_a”);
    }
    if (sb != “”){
    jQuery(“body”).css(“background-image”,”url(‘img/bg/” + sb + “.png’)”);
    jQuery(“body”).css(“background-repeat”,”repeat”);
    if((sb == “pattern_bg_a”)||(sb == “pattern_bg_b”)||(sb == “pattern_bg_c”)) {
    jQuery(“body”).css(“background-image”, “url(img/bg/” + sb + “.jpg)”);
    jQuery(“body”).css(“background-repeat”,”repeat-y”);
    jQuery(“body”).css(“background-position”,”center top”);
    }
    }
    localStorage.clear();`
    before it add:
    if ( !jQuery.browser.msie ) {
    after it add:
    }
    two problem will be fixed,
    Best

    • This reply was modified 4 years ago by  Johnny.
    #795

    maps75
    Participant

    Thank you.

    The LayerSlider is OK now.
    But the align left don’t.

    I checked that the variables sw, sh and sb are null.

    Can you verify, please?

    Best.

    Marco Antonio / Brazil.

    #799

    Johnny
    Participant

    hi, I can not find the alignment issue under IE(see p3.jpg),
    to let the header align left under other browsers, please add a little code in main.js(see p4.jpg),
    Best

    #802

    maps75
    Participant

    LOL…
    Here in Brazil we named it: “gambiarra”.
    Forcing the value of variable, ok. But isn’t the correct way…
    The error of the align occurs on Google Chrome and Firefox.
    Now, is all ok.

    Thank you so much.

    Best.

    Marco Antonio / Brazil

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.