Home Forums Arnold WordPress Theme change link text styling to underline in pages and post

This topic contains 13 replies, has 2 voices, and was last updated by  cincin 1 month ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #16661

    cincin
    Participant

    hi,

    could you kindly advise how to change the link text styling in pages and posts to underline?

    thank you!

    #16680

    BWSM
    Keymaster

    HI
    Please paste the custom css code to “Appearance > Customize : Additional CSS”

    .menu-item:hover > a:after, .menu-item:focus > a:after, .socialmeida-a:hover .socialmeida-text:after, .socialmeida-a:focus .socialmeida-text:after, .menu-item.current-menu-item > a:after, .menu-item.active > a:after, .portfolio-link-button-a:hover:after, .archive-more-a:hover:after, .gallery-link-a:hover:after, .gallery-link-a:focus:after, .wpml-translation li:hover span:after, .wpml-translation .current-language > span:after {
        opacity: 1;
        -webkit-transform: translateY(0);
        -moz-transform: translateY(0);
        -ms-transform: translateY(0);
        transform: translateY(0);
    }

    Regards!

    #16682

    cincin
    Participant

    hi,

    i probably didn’t explain well my question, i would like to change the links ONLY in PAGES (eg. about) and POSTS to underline, not to menu or footer.

    thank you!

    #16694

    BWSM
    Keymaster

    Pleaes update the css

     .portfolio-link-button-a:hover:after, .archive-more-a:hover:after, .gallery-link-a:hover:after, .gallery-link-a:focus:after, .wpml-translation li:hover span:after, .wpml-translation .current-language > span:after {
        opacity: 1;
        -webkit-transform: translateY(0);
        -moz-transform: translateY(0);
        -ms-transform: translateY(0);
        transform: translateY(0);
    }
    #16704

    cincin
    Participant

    Hi thank you for your reply, however the pages remained unchanged, could you kindly look into the codes? thank you!

    #16716

    BWSM
    Keymaster

    Please leave the URL, thanks!

    #16718

    cincin
    Participant
    This reply has been marked as private.
    #16719

    BWSM
    Keymaster

    Please paste the custom css code to “Appearance > Customize : Additional CSS”

    .panel-widget-style a:after,.entry a {
        content: '';
        opacity: 0;
        position: absolute;
        width: 100%;
        height: 100%;
        right: 0;
        bottom: -1px;
        border-bottom: 1px solid currentColor;
    }
    .panel-widget-style a:hover:after,.entry a:hover:after  {
        opacity: 1;
        -webkit-transform: translateY(0);
        -moz-transform: translateY(0);
        -ms-transform: translateY(0);
        transform: translateY(0);
    }
    #16724

    cincin
    Participant
    This reply has been marked as private.
    #16734

    BWSM
    Keymaster

    Please update the CSS as:

    
    .panel-widget-style a,.entry a {
    position: relative;
    }
    .panel-widget-style a:after,.entry a:after {
        content: '';
        opacity: 0;
        position: absolute;
        width: 100%;
        height: 100%;
        right: 0;
        bottom: -1px;
        border-bottom: 1px solid currentColor;
    }
    .panel-widget-style a:hover:after,.entry a:hover:after  {
        opacity: 1;
        -webkit-transform: translateY(0);
        -moz-transform: translateY(0);
        -ms-transform: translateY(0);
        transform: translateY(0);
    }
    • This reply was modified 1 month ago by  BWSM.
    #16736

    BWSM
    Keymaster
    This reply has been marked as private.
    #16737

    cincin
    Participant
    This reply has been marked as private.
    #16750

    BWSM
    Keymaster

    You have set the height color as gray color, you can change it in theme option.
    or you can set the link color by CSS:

    .panel-widget-style a,.entry a {
    color: #414145;
    }
    #16751

    cincin
    Participant

    thank you so much!

Viewing 14 posts - 1 through 14 (of 14 total)

The topic ‘change link text styling to underline in pages and post’ is closed to new replies.