Home Forums Aside WordPress Theme Blog list thumbnails link to post

This topic contains 20 replies, has 3 voices, and was last updated by  STrajkovski 4 years ago.

Viewing 21 posts - 1 through 21 (of 21 total)
  • Author
    Posts
  • #3532

    Johnny
    Participant

    bsundman:
    Hi, I like theme but i would like the featured images for posts on the homepage (and all other pages) to link to the actual post instead of a lightbox of that image. I think this is a big user experience issue, as some users may not know to click on the post title to view the full post. How would I go about doing that? Thanks.

    Hi, please open file functions/pagebuilder/modules/blog.php and find this:
    <a href="<?php echo $thumb_src_full[0]; ?>" class="lightbox liqd-gallery-img" rel="post<?php the_ID(); ?>" title="<?php the_title(); ?>">
    update it to:
    <a href="<?php the_permalink(); ?>" class="liqd-gallery-img" rel="post<?php the_ID(); ?>" title="<?php the_title(); ?>">
    Best

    #3539

    bsundman
    Participant

    Thanks for the quick reply! That did exactly what I want but just for the portfolio posts and not standard posts. Could you please add a fix for the standard posts as well? Thanks again!

    #3540

    Johnny
    Participant

    Hi, same file and find other 3 ‘a’ tags with the class ‘lightbox’, remove word ‘lightbox’ and update
    href="<?php echo $thumb_src_full[0]; ?>"
    to
    href="<?php the_permalink(); ?>"
    Best

    #4279

    STrajkovski
    Participant

    I did the above, but now the featured images are very large (probably increased in size by 300%), and a small ‘eye’ icon is shown under the title of the blog post.

    #4282

    Johnny
    Participant

    Hi, please make sure you updated the accurate scripts. this does not relate to images.
    Thank you

    #4283

    STrajkovski
    Participant

    Thanks for your prompt response. When you say “other 3 ‘a’ tags with the class ‘lightbox’, remove word ‘lightbox’”, do you mean simply delete the word Lightbox from between the inverted comas? I’m pretty confident I updated the correct scripts, but I’ll give it another try.

    #4285

    STrajkovski
    Participant

    I restored the original blog.php file and went through the steps above, but I got the same result.

    Any other ideas?

    #4294

    Johnny
    Participant

    Hi, paste your page url here please, I will check it later,
    Thank you

    #4295

    STrajkovski
    Participant
    This reply has been marked as private.
    #4302

    Johnny
    Participant

    Hi, paste your page url here please. I need to determine whether the page comes from blog.php.
    Thank you

    #4319

    STrajkovski
    Participant
    This reply has been marked as private.
    #4324

    Johnny
    Participant

    Hi, please paste you page url which you want the lists link to posts rather than to lighbox. only a site url I can determine nothing.
    Thank you

    #4332

    STrajkovski
    Participant
    This reply has been marked as private.
    #4333

    Johnny
    Participant

    Hi, I have checked your page and confirmed it is comes from blog.php. please make sure update the script according to the first post of this thread. if still not working please manage clear your server/browser caches.
    Thank you

    #4335

    STrajkovski
    Participant

    Okay, thanks.

    I just re-tried it, and worked out my issue. Sorry for wasting your time. It worked. However, for the benefit of everyone else, in the last ‘a href’ line of code which contains the word ‘lightbox’, only remove the word ‘lightbox, not all of the text within the inverted comas (that is: ‘lightbox ux-hover-wrap’).

    Also, I must note that the preview/thumbnail of my blog post featured images is now roughly 300% again, as I mentioned earlier.

    #4336

    STrajkovski
    Participant

    Further to my comment above, altering these settings (which you advised on earlier) does not affect the size of the image preview now.

    Hi, please try update styles/pagebuild.css line 1683 or about:
    .blog-item-img{…height:200px;…}
    to
    .blog-item-img{…height:auto;…}
    Best

    #4339

    Johnny
    Participant

    Hi, maybe your blog.php layout has broken. see attached image please.
    Thank you

    #4355

    STrajkovski
    Participant

    I’m not sure what I’m looking at when I read that code. How can I fix that? What should it look like?

    #4359

    Johnny
    Participant

    Hi, have you ever changed blog.php? please make sure modified a tag with the right format something like this:
    <a href="..." class="...">
    Best

    #4361

    STrajkovski
    Participant

    Yes, of course I have modified the blog.php. I’ll check the a ref tags and see if i can find any which don’t match…

    #4362

    STrajkovski
    Participant

    I found the issue. I added an extra > on the end, and it fixed the size of the images. Thanks for being patient with me.

Viewing 21 posts - 1 through 21 (of 21 total)

You must be logged in to reply to this topic.