Home Forums Bee WordPress Theme WPML vs Pagebuilder?

This topic contains 15 replies, has 3 voices, and was last updated by  lunte02 3 years ago.

Viewing 16 posts - 1 through 16 (of 16 total)
  • Author
    Posts
  • #1900

    lunte02
    Participant

    Hi guys,

    as I have to set up a multilanguage-site, I’ve implemented the WPML-plugins.
    At the moment the WPML only translate the content made by the classic editor.
    Is there a way to translate the content made by the Pagebuilder?

    Regards,
    lunte

    #1901

    BWSM
    Keymaster

    Hi lunte, the translation of builder option is same as the classic editor. Could you give more detail? Better leave your wp-admin url / usename/ pass by “Set as private reply”.

    Best,
    Fan

    #2067

    lunte02
    Participant
    This reply has been marked as private.
    #2075

    BWSM
    Keymaster

    Hi,

    I visited your wp-admin. I can’t create multi-language post/page even using wp defult theme(Twenty Thirteen). It was shown the tips: http://d.pr/i/4sip . It is not the theme problem. Please check the WPML config or other things.

    Best

    #2159

    lunte02
    Participant
    This reply has been marked as private.
    #2164

    BWSM
    Keymaster

    Hi

    The pencil icon could be clicked (http://d.pr/i/qsyU ). After click the page: http://d.pr/i/uD4T
    I created a post in my test site. You could visit the link: http://115.28.49.212/wordpress/bee/2014/01/15/post-test/
    (turn to German by the selector in sidebar or flag in top bar)

    Best

    • This reply was modified 3 years, 3 months ago by  BWSM.
    #2885

    lunte02
    Participant

    Hi BWSM,

    I’m still stuck with WPML-Plugin translating the Page-Builder-content.

    The content of the basic WYSISWYG-editor is shown in the i.e. english version of the page. This works. But somehow I can’t choose the pagebuilder to be translated on the english version of the page.

    Is there a basic WPML-setup to include your pagebuilder-tool in the circle of “to be translated content” which I simply oversee or should it be like

    + installing the plugin
    + setting up language
    + fine lets go?

    My client really steams up and it would be great if you could help again.

    Thanks,
    lunte02

    #2886

    lunte02
    Participant

    Hi BWSM,

    after tinkering with the settings again I found out the following:
    if I set up WPML to “create translation manually” under “Translation-Management” it includes the pagebuilder.
    If I set it to “Use Translation editor” WPML ignores the pagebuilder.

    Do you know what to choose to include the PB in the Translation-Manager?

    Thanks,
    lunte02

    #2887

    Johnny
    Participant
    #2922

    lunte02
    Participant

    Hi Urmy,

    nope – pittyly the settings describe under that link don’t help. For my site it stays the same: the items build by the pagebuilder won’t appear at the translationsite (see enclosed screens).

    BWSM answered on the 24th of January that he set up a test site where the described thing (pagebuilder-content is translated by WPML) seems to work. But he never revealed how he setup WPML to achieve this (see entry above).

    Could he or you provide these informations. Perhaps this would finally solve the case!?

    Thanks again for your help,

    lunte02

    #2945

    BWSM
    Keymaster

    Hi,

    after tinkering with the settings again I found out the following:
    if I set up WPML to “create translation manually” under “Translation-Management” it includes the pagebuilder.
    If I set it to “Use Translation editor” WPML ignores the pagebuilder.
    Do you know what to choose to include the PB in the Translation-Manager?

    I logged in your wp-admin to test again.
    Sorry, i don’t know how to make it to Translation-Manager now. It seems that you must translate it by manually(different pages/posts by each language). My WPML is older version, i need to install a latest version to test some days.

    Best

    • This reply was modified 3 years ago by  BWSM.
    • This reply was modified 3 years ago by  BWSM.
    #2957

    lunte02
    Participant

    Hi BWSM,

    I can setup the Tranalation-Manager back to “Use translation Manager” to help you check it out.

    From the other side: how do you set up your system to include the pagebuilder in the translated page?

    At your testblog it seems to workd. Or did you scracth-build the pagebuilder-modules at the translated (german) blog-entry?

    Did you need to specially configure the WPML-Plugin or did it just work out of the box right after installing WPML?

    Best Regards,
    lunet

    #2973

    BWSM
    Keymaster

    Hi lunet,

    I translated the pagebuilder page(test blog) by manually.

    Or did you scracth-build the pagebuilder-modules at the translated (german) blog-entry?

    Yes.

    Best!
    Bwsm

    • This reply was modified 3 years ago by  BWSM.
    #2984

    lunte02
    Participant
    This reply has been marked as private.
    #2996

    BWSM
    Keymaster

    Hi

    The Pagebuilder translation way:

    1. Go to WPML/Translation-Management”, make sure “Translation manualy” selected

    2. Created a new page(make sure under default language), set to Pagebuilder editor, put in some Pagebuilder modules, click publish

    3.
    3.1 Check ‘Duplicate’ checkbox and click on “Duplicate” button (see the screenshot below) at the right sidebar. “Duplicate” button will be displayed after checking of checkbox;
    3.2 Click the pencil icon to translate the page.

    4. When you edit the the page on non-default language, plz click “Translate independently” button at the right sidebar. Otherwise all your translations can be replaced by default content.

    #3008

    lunte02
    Participant
    This reply has been marked as private.
Viewing 16 posts - 1 through 16 (of 16 total)

You must be logged in to reply to this topic.