Home Forums Travel WordPress Theme the menu link not work

This topic contains 13 replies, has 2 voices, and was last updated by  Johnny 3 years, 4 months ago.

Viewing 14 posts - 1 through 14 (of 14 total)
  • Author
    Posts
  • #3781

    Johnny
    Participant

    nunoyobiz:
    I wrote you the following comment on Themforest.net for the Travel Fullscreen Responsive Ajax WordPress Theme. First of all, thank you very much for your help and for doing what you can to help me with my issues.

    This is what I wrote on Themeforest:
    Thank you so much for your help! That really helped me out a ton! But I found something out.. since the links in the menu load in the same page without going to another url, the animations im using with a shortcode dont work, but when i go to that url (i.e. .com/post-name) they work perfectly.

    Apart from that, I am also having problems with certain shortcodes. They show up like they dont have any css format. I am using GT3 Pagebuilder to do some things but they dont show up.

    This is the URL:
    http://www.makariomusic.com/bacano
    The page I am currently working on is “Viajeros”.

    Hi, I have check your site here:
    and find an error in gt3-pagebuilder js file.
    please try this to resolve it:
    open file bacano/wp-content/plugins/gt3-pagebuilder/js/pb-modules.js and find this:

    jQuery(window).resize(function(){
    	if ($('.fw_gallery').size() > 0) {
    		if (jQuery('.content_block').hasClass('no-sidebar')) {
    			if (jQuery('html').hasClass('user_bg_layout')) {
    				$('.fw_gallery').css('margin-left' , -1*(jQuery('.main_wrapper').width()-jQuery('.container').width())/2+'px').width(jQuery('.main_wrapper').width());
    			} else {
    				$('.fw_gallery').width($(window).width()).css('margin-left', -1*(jQuery(window).width()-jQuery('.container').width())/2+'px');
    			}
    		}				
    	}

    replace all $ to jQuery.
    any problem please let me know.
    Thank you

    #3793

    nunoyobiz
    Participant

    Thank you for looking into this, but I dont know if I understood correctly.
    You want me to change all ‘$’ and replace with ‘jQuery’? I tried that but it didn’t work 🙁
    Is there anything else I can do?

    #3798

    Johnny
    Participant

    Hi, please make sure you have updated the script I mention you previous. I have checked you site here: http://makariomusic.com/bacano/, nothing changed, see attached image.
    Best

    #3801

    nunoyobiz
    Participant

    So instead of

    jQuery(window).resize(function(){
    	if ($('.fw_gallery').size() > 0) {
    		if (jQuery('.content_block').hasClass('no-sidebar')) {
    			if (jQuery('html').hasClass('user_bg_layout')) {
    				$('.fw_gallery').css('margin-left' , -1*(jQuery('.main_wrapper').width()-jQuery('.container').width())/2+'px').width(jQuery('.main_wrapper').width());
    			} else {
    				$('.fw_gallery').width($(window).width()).css('margin-left', -1*(jQuery(window).width()-jQuery('.container').width())/2+'px');
    			}
    		}				
    	}
    

    It would be this?

    jQuery(window).resize(function(){
    	if (jQuery('.fw_gallery').size() > 0) {
    		if (jQuery('.content_block').hasClass('no-sidebar')) {
    			if (jQuery('html').hasClass('user_bg_layout')) {
    				jQuery('.fw_gallery').css('margin-left' , -1*(jQuery('.main_wrapper').width()-jQuery('.container').width())/2+'px').width(jQuery('.main_wrapper').width());
    			} else {
    				jQuery('.fw_gallery').width(jQuery(window).width()).css('margin-left', -1*(jQuery(window).width()-jQuery('.container').width())/2+'px');
    			}
    		}				
    	}
    
    #3802

    nunoyobiz
    Participant

    Hello,
    I disabled GT3 builder to try other plugins and shortcodes, but i have the same problem. When I click on the Viajeros page from the index page, the shortcodes dont have any format (image 1) but when i open Viajeros on another tab the shortcodes do have format (image 2).

    #3805

    Johnny
    Participant

    Yes, it is.

    #3806

    Johnny
    Participant

    Hi, please try this:
    open file footer.php and add below codes right before this </body>:
    <link rel="stylesheet" id="su-box-shortcodes-css" href="http://makariomusic.com/bacano/wp-content/plugins/shortcodes-ultimate/assets/css/box-shortcodes.css?ver=4.9.0" type="text/css" media="all">
    Best

    #3808

    nunoyobiz
    Participant

    You are awesome!!!! So, if I need to “force” another shortcode to work, do i need to link the css in the footer?

    #3809

    nunoyobiz
    Participant

    Also, what can I do about the animations? I have a shortcode that animates things but it only works when I am on the page url and not from index.

    #3819

    Johnny
    Participant

    Hi, something you should do like previous guided. find the script references and then add it to the footer.php.
    Best

    #3825

    nunoyobiz
    Participant

    I did it the same way you told me to put the styelsheet above, but it didnt work. I also tried registering it and enqueue-ing it but nothing. Animations only work on the page and not clicking from index. Maybe I did it wrong?
    I put this:

    <script type="text/javascript" src="http://www.makariomusic.com/bacano/wp-content/plugins/animate-your-content/js/ayc.js?ver=3.9.1"></script>
    

    with this code in the functions file

    function load_animate_this_content ()
    {
    	wp_register_script( 'animate-content', 'http://www.makariomusic.com/bacano/wp-content/plugins/animate-your-content/js/ayc.js', 'jquery', false, true);
        wp_enqueue_script( 'animate-content' );
    }
    add_action( 'wp_enqueue_scripts', 'load_animate_this_content' );
    
    #3828

    Johnny
    Participant

    Hi, please don’t register the plugin script from functions.php. try add this script:
    <script type="text/javascript" src="http://www.makariomusic.com/bacano/wp-content/plugins/animate-your-content/js/ayc.js?ver=3.9.1"></script>
    to footer.php.
    Thank you

    #3832

    nunoyobiz
    Participant

    I did it but I had no luck :(.

    #3835

    Johnny
    Participant

    Hi, I have checked your site and find that ayc.js loaded in head tag 2 times, and not from footer. please manage fix it.
    Thank you

Viewing 14 posts - 1 through 14 (of 14 total)

You must be logged in to reply to this topic.