Home Forums Flowfolio WordPress Theme showing up the posts in the list along the scroll

This topic contains 6 replies, has 2 voices, and was last updated by  tariel 3 years, 2 months ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #3323

    tariel
    Participant

    When I scroll the list on the first page [http://tarielzivzivadze.ge] all the posts are shown already.
    How to change that into the following way:
    I want the posts after the 6-th one show up if the user scrolls till that one? [like it is shown in the demo]
    thx

    #3328

    Johnny
    Participant

    Hi, please set your list page option ‘Number of posts per page’ as attached image showing.
    Best

    #3346

    tariel
    Participant

    it took me a while to find out where that part was
    and it appeared that I did not have a list page at all
    therefore (probably) the homepage snippet in Google search was changing every time I was adding a post there

    so
    1. I created the list page with its unique URL indicating that only 6 posts load instantly, the rest after scroll
    2. I indicated that list page in the Settings >> Reading >> Front page display as a static page for for front page

    The problems are:
    1. I can see the list page in the page list, but it has no unique URL not. instead, it shows the main URL. Is it because I use it as a static page?
    2. When I scroll all the posts after the 6 ones, have sizes changed.

    Is it normal? Did I do it right?

    #3358

    Johnny
    Participant

    Hi, I have checked your site. all you done are very good, no problem. you created list page will be assignment to front page by wordpress system, no need to worry about it. the scroll component is called ‘infinite scroll’, it will add posts automatically while scrolling.
    Best

    #3370

    tariel
    Participant

    nice, thx

    Only problem left here is the following: I have indicated 6 posts as “open”. When the other posts load in when scrolling, the width of the loaded posts are automatically resized from 400 px into 320 px.

    Can that be corrected?

    #3377

    Johnny
    Participant

    Hi, please open file style.css and find this:
    .unit_excerpt { float:right; width:320px; padding:20px 20px 0px 20px; font-style:italic; font-weight:300; color:#ababab; background:#fff; }
    update it to:

    .unit_excerpt { float:right; width:400px; padding:20px 20px 0px 20px; font-style:italic; font-weight:300; color:#ababab;  background:#fff; }
    Best
    #3379

    tariel
    Participant

    thank you
    its working 🙂

Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.