Home Forums Theone WordPress Theme Mobile menu is messed up

This topic contains 12 replies, has 2 voices, and was last updated by  BWSM 2 years, 5 months ago.

Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #7385

    PowerHouz
    Participant

    The links on the mobile menu seem broken. There seems to be an error with the #top tag. Sometimes I noticed this error in the regular size menu too.

    They only work when im not anchoring them to the #top tag, but I need the links to go to the top of the page so the user doesnt have to scroll up.

    When I set anchor as “none” the BM slider on each page brakes…

    #7386

    PowerHouz
    Participant

    The page is Zysco

    • This reply was modified 2 years, 6 months ago by  PowerHouz.
    #7390

    BWSM
    Keymaster

    please leave your wp-admin(url/user/pass) as private reply, I’ll log in to check it.

    Best,Bwsm

    #7399

    PowerHouz
    Participant
    This reply has been marked as private.
    #7403

    BWSM
    Keymaster

    If you want to hide “#top” on link, the fullwidth of this page would not be set Anchor Name.

    If you want to set a page as “onepage”(with multi anchors), please use lowercase letters for “Anchor Name” and slug name of Page, do not use spaces and other characters

    #7404

    PowerHouz
    Participant

    Ok, I did like you said and changed all anchors and slugs to lower-case with no spaces. But I dont understand the part about hiding #top. I still cant get to a primary menu link by clicking directly on it. For example if im on the homepage i cant click on the primary SERVICES link but I can do it on the submenu. This only happens on mobile btw.

    #7405

    PowerHouz
    Participant

    if im on a page and try to link one of the primary menu links it just goes to the top of the current page. How can I solve that. Also if I disable the fade-in loading effect the links stop working on the desktop view too.

    #7406

    BWSM
    Keymaster

    There is a way to remove #top: when you edit the menu item every time, re-choose the “none” (https://www.dropbox.com/s/f9wnbk9m8l5q6lc/QQ20150529-1.jpg?dl=0).
    Because the anchor selector can not be stay on “none” after save, we’ll fix it as soon.

    I noticed there is some cache on your site even I closed the super cache settings, when I edit the menu, I refresh the front page, it isn’t updated. I need refresh the front page twice at least, it would be updated.

    #7408

    PowerHouz
    Participant

    Yep I know that setting them to “none” kind of fixes the problem, but as soon as I anchor them to “none” the slider and other things break on the page.

    Like here, in the homepage the slider is missing in the top and on the clients wrap the images are all messed up

    • This reply was modified 2 years, 5 months ago by  PowerHouz.
    #7410

    PowerHouz
    Participant

    I mean, it seems it breaks some of the JS: “Uncaught TypeError: Cannot read property ‘split’ of undefined: jquery.onepagenav.js?ver=3.0.0:21”

    #7411

    BWSM
    Keymaster

    You have to set “#top” for “Welcome” menu item for homepage(it should not be set “none” for home page in my screenshot), same as service page, set “#top” for service page. So, you need 2 menus if you want to use anchor for service page also. You could consider to use this plugin: https://wordpress.org/plugins/menu-per-pages/

    #7419

    PowerHouz
    Participant

    Ok, the issue with the menu was actually part of jquery.onepagenav.js, I found the culprit if it helps someone:

    I kept getting Uncaught TypeError: Cannot read property ‘split’ of undefined in

    getHash: function($link) {
    return $link.attr(‘href’).split(‘#’)[1];
    },

    until changed it to

    getHash: function($link) {
    return ($link.attr(‘href’))? $link.attr(‘href’).split(‘#’)[1] : ”;
    },

    #7420

    BWSM
    Keymaster

    Thanks for sharing.

Viewing 13 posts - 1 through 13 (of 13 total)

You must be logged in to reply to this topic.