Home Forums Aside WordPress Theme I can't change the font

This topic contains 16 replies, has 4 voices, and was last updated by  BWSM 8 months, 2 weeks ago.

Viewing 17 posts - 1 through 17 (of 17 total)
  • Author
    Posts
  • #4476

    harudsgn
    Participant

    Hi,

    I updated all google font and I chose Raleway but it doesn’t appear on my website.
    How may I process ?

    Thanks.

    #4479

    BWSM
    Keymaster

    HI

    please leave your wp-admin(url/user/pass) by “Set as private reply”, I need to login to check it

    Best,Bwsm

    #4482

    harudsgn
    Participant
    This reply has been marked as private.
    #4486

    BWSM
    Keymaster

    It missed a style php file, so I install a latest version theme. It works now.

    #11634

    Danny007
    Participant

    I cant change almost everything in settings of “aside”:
    1. font size in posts
    2. logo size
    Do you think i missing style php file too?

    #11637

    BWSM
    Keymaster

    Hi Danny007

    please send your wp-admin(url/user/pass) via my profile contact form , I’ll log in to check it.

    #11671

    jsmexpo
    Participant

    Interesting thread. Where should this file be located? I couldn’t find it either. All my fonts and style settings got mixed up after moving from http to https (swapping all the mysql strings from http to https).

    #11672

    BWSM
    Keymaster

    Hi jsmexpo

    Please check if installed the right theme file. SHOULD install the aside.zip(NOT aside-main.zip). Please remove the theme, re-install the aside.zip (un-zip aside-main.zip, you’ll see it). screenshot

    If it still doesn’t work, please send your wp-admin(url/user/pass) via my profile contact form , I’ll log in to check it.

    #11673

    jsmexpo
    Participant

    Thank you very much for your help. Re-installed exactly “aside.zip”, didn’t help 🙁
    So I’ve just sent you a message via ThemeForest.

    #11674

    jsmexpo
    Participant

    I see the trouble now. My browser assumes that as the website works at https, it can’t load any third-party scripts (i.e. google fonts) – so if you force the browser to load them, it more or less takes the shape.. But it is no longer secure connection at the browser’s opinion. is there a way to get it via https?
    These ones:
    “http://fonts.googleapis.com/css?family=Roboto%3A400%2C400italic%2C700%2C900&ver=0.0.1”

    #11675

    jsmexpo
    Participant

    Just found out that they are available at the same URLs but at https instead of http. Just need to find the file now with the reference to these… no luck so far.

    p.s. sorry for replying my own replies – this is the only message I could edit. Weird.

    #11676

    BWSM
    Keymaster

    Hi jsmexpo,

    Please find /functions/theme/theme-register.php, line 169:
    wp_register_style('google-fonts-' . $family_val, 'http://fonts.googleapis.com/css?family=' . $family_val . ':' . trim($output, $separator));
    update to:
    wp_register_style('google-fonts-' . $family_val, 'https://fonts.googleapis.com/css?family=' . $family_val . ':' . trim($output, $separator));

    p.s. sorry for replying my own replies – this is the only message I could edit. Weird.

    I’ll check the forum later. can you send new topic?

    #11677

    jsmexpo
    Participant

    Thanks, did that. Didn’t help 🙁
    Still have the same issues:
    1. Fonts won’t load if you don’t force the browser to “use unsafe location”

    Debugging

    2. Fonts won’t show on the “font settings” tab of the “theme options” in wp admin.

    Google fonts

    can .htaccess be the reason?

    p.s. “edit” function works fine now.

    #11678

    jsmexpo
    Participant

    Just realized I’ve posted old htaccess
    Here is the up-to-date one, that has forwarding to port 443

    “edit” is not working again ((

    #11685

    BWSM
    Keymaster

    1. based on this screenshot, the google fonts should comes from Revolution Slider plugin.
    But I can’t see the error on your site. Please let me know which page url show the errors?

    2. You could use old .htaccess to “update google font data”, after update, use new .htaccess again. Because the update need run only once.

    FW: please change the default google font http as https
    in /functions/interface/interface-register.php:

    $style['ux-googlefont-rotobo'] = array(
    		'handle' => 'ux-googlefont-rotobo',
    		'src'    => 'http://fonts.googleapis.com/css?family=Roboto:400,400italic,700,900',
    		'deps'   => array(),
    		'ver'    => '0.0.1',
    		'media'  => 'screen'
    	);	
    
    	$style['ux-googlefont-playfair'] = array(
    		'handle' => 'ux-googlefont-playfair',
    		'src'    => 'http://fonts.googleapis.com/css?family=Playfair+Display:700',
    		'deps'   => array(),
    		'ver'    => '0.0.1',
    		'media'  => 'screen'
    	);
    #11688

    jsmexpo
    Participant

    Awesome! Thank you! Amending interface-register.php solved the “mixed content” problem entirely.
    Going to give you 5 stars this time ))

    #11695

    BWSM
    Keymaster

    Thank you, I would greatly appreciate.

Viewing 17 posts - 1 through 17 (of 17 total)

You must be logged in to reply to this topic.