Home Forums Arnold WordPress Theme Featured image cropping on custom grid portfolio

This topic contains 6 replies, has 2 voices, and was last updated by  BWSM 1 week, 2 days ago.

Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
    Posts
  • #12890

    laaksolaakso
    Participant

    Hi.

    I can’t get the featured images crop properly on the custom grid portfolio. It keeps zooming in to my images and crops it so that the whole image doesn’t show up. Have tried different image sizes, image ratios everything I can up with! Think the problem is already in the gallery post where it creates the thumbnail; it wont let me make it portrait but it always makes them squares.

    What is wrong with it? And how to get it work? Need some help asap please.

    #12891

    laaksolaakso
    Participant
    This reply has been marked as private.
    #12902

    BWSM
    Keymaster

    Hi,

    The cropped ruler is for image size optimization. We’ll consider add a option to use the original image next version.

    There is quick fixing way:

    Please find /functions/interface/interface-function.php, line 586-594:

    thumbnail size in custom grid portfolio Arnold

    update as:

    if( $width > 3 && $width <= 7 ) {
    	$thumb = wp_get_attachment_image_src(get_post_thumbnail_id(), 'full');
    } elseif($width > 7 && $width < 11) {
    	$thumb = wp_get_attachment_image_src(get_post_thumbnail_id(), 'full'); 
    } elseif($width >= 11) {
    	$thumb = wp_get_attachment_image_src(get_post_thumbnail_id(), 'full'); 
    } else {
    	$thumb = wp_get_attachment_image_src(get_post_thumbnail_id(), 'full');
    }

    Regards!
    Bwsm – uiueux.comTwitterFacebook

    #12931

    laaksolaakso
    Participant

    Thanks for your respond.

    If I change that code and upload the theme on my wp again, will I loose all my settings and content? Or is there a way to modify that file without uploading the whole theme again?

    #12941

    BWSM
    Keymaster

    Yes, it will be covered after theme updated.
    Please upgrade the Arnold theme, the option was added.

    • This reply was modified 1 week, 2 days ago by  BWSM.
    #12955

    laaksolaakso
    Participant

    Sweet, appreciate it but it says the themes are up to date?

    #12956

    BWSM
    Keymaster

    Plz go to Appearance > Theme Options > Layout , activate “Use Original Images for Thumbnails”,


    if still doesn’t work, please send your wp-admin(url/user/pass) via my profile contact form , I’ll log in to check it.

    • This reply was modified 1 week, 2 days ago by  BWSM.
Viewing 7 posts - 1 through 7 (of 7 total)

You must be logged in to reply to this topic.