Home Forums Fashionic WordPress Theme Child-theme doesn`t work

This topic contains 5 replies, has 2 voices, and was last updated by  andalusi 4 years, 2 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
    Posts
  • #214

    andalusi
    Participant

    Hi there,

    I would like to customized your theme, unfortunately I get an php-Error when activate the child-theme.

    I uploaded a new directory called “fashionic-child”. In there is only one file “style.css”.

    When I activedet the child-theme and click on the preview button I see this:

    Warning: require_once(/home/httpd/vhosts/windimgrind.ch/httpdocs/wp-content/themes/fashionic-child/functions/option/options-framework.php) [function.require-once]: failed to open stream: No such file or directory in /home/httpd/vhosts/windimgrind.ch/httpdocs/wp-content/themes/fashionic/functions.php on line 603
    
    Fatal error: require_once() [function.require]: Failed opening required '/home/httpd/vhosts/windimgrind.ch/httpdocs/wp-content/themes/fashionic-child/functions/option/options-framework.php' (include_path='.:/usr/share/pear:/usr/share/php') in /home/httpd/vhosts/windimgrind.ch/httpdocs/wp-content/themes/fashionic/functions.php on line 603

    Please help!

    Best, Andreas
    Munich

    #217

    BWSM
    Keymaster

    Hi, Andreas

    Please add a folder named functions in fashionic-child folder,

    Copy the option folder (\fashionic\functions\option) in \fashionic-child\functions

    #218

    andalusi
    Participant

    Great themes, great support!
    Thanks 🙂

    #219

    andalusi
    Participant

    Ok, now I can use the child-theme.

    But the stylesheet in “fashionic-child” has no effect.
    I would like to overwrite some things but won`t use the “Custom Css” area in the “Fashionic Theme Options” due to lack of syntax highlighting. Also I have to use a lot of “!important” tags, as well.

    Here is my style.css in fashionic-child folder:

    
    /*
    Theme Name:     Fashionic Child Theme 
    Template:       fashionic                            
    */
    
    @import url("../fashionic/style.css");
    

    Changes in this file has no effect in my theme 🙁

    Best, Andreas
    Munich

    #224

    BWSM
    Keymaster

    Please remove line 103 in fashionic/functions.php

    wp_register_style('panda-style', UX_LOCAL_URL . '/style.css', array(), '1.5', 'screen');

    change line 112 in functions.php

    wp_enqueue_style('panda-style');

    as

    wp_enqueue_style( 'fashionic-style', get_stylesheet_uri() );

    • This reply was modified 4 years, 2 months ago by  BWSM.
    • This reply was modified 4 years, 2 months ago by  BWSM.
    #227

    andalusi
    Participant

    Now it works!

    Thanks…

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.